Alte PHP Version – Langzeitsupport für PHP 5.2 – PHP 7.3

In den letzten Tagen mehren sich wieder Anfragen ob PHP Versionen vor 7.0, wie PHP 5.6, PHP 5.4 oder PHP 5.2 noch unterstützt werden.

Zahlreiche Webseitenbetreiber sind damit konfrontiert, dass verschiedene Provider und Hoster, PHP Versionen vor PHP Version 5.6 bei manchen Hostingprodukten aufgrund „End of Life“ dieser PHP Versionen nicht mehr unterstützen.

Manche Webseiten und Homepages blieben sogar leer, da sie nach dem Umschalten auf PHP 7.0 oder neuer, nicht mehr funktionierten.

Ältere TYPO3 CMS, spezifisch erstellte Homepage oder im Auftrag programmierte Plugins für CMS Systeme wie Joomla oder Blogs wie WordPress funktionieren nicht mehr.

peaknetworks bietet eine Langzeitunterstützung von älteren PHP Versionen, dabei portieren wir die älteren PHP Interpreter auf die neuesten Betriebssystemversionen. Bei Sicherheitsproblemen patchen wir die durch die eigenen Softwareentwicklung ältere PHP Interpreter auf peaknetworks Webservern selbst.

PHP Interpreter Logo

Unterstützungszeitraum

VersionMindestens unterstützt bisBemerkung  
PHP 5.2Ende 2022FastCGI
PHP 5.4Ende 2022PHP FPM
PHP 5.6Ende 2024PHP FPM
PHP 7.0Ende 2026PHP FPM
PHP 7.1Ende 2026PHP FPM
PHP 7.2Ende 2026PHP FPM
PHP 7.3Ende 2026PHP FPM

PHP Version im peaknetworks Controlpanel

Im peaknetworks Controlpanel kann die gewünschte PHP Version in jedem Verzeichnis separat eingestellt werden:

Hier finden Sie eine Übersicht über die Hosting Produkte  mit PHP 5 und PHP 7.